コメント/Mosh/autotools/problem の変更点



 [[Mosh/autotools/problem]]
 
 -libtoolでエラー(r1260,gc-7.1alpha3) -- [[.mjt]] &new{2009-03-02 (月) 18:43:04};
  libtool: Version mismatch error.  This is libtool 2.2.6, but the
  libtool: definition of this LT_INIT comes from libtool 2.2.4.
  libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
  libtool: and run autoconf again.
 --遡ってみました。r1251 のココサブさんによる変更が最新ですね> gc-7.1alpha3 。ココサブさんの環境に 2.2.4 "も" 入っていて使われてしまっているとか? -- [[ひげぽん]] &new{2009-03-02 (月) 19:32:59};
 --ココサブさんがコミットされた aclocal.m4 には m4_define([LT_PACKAGE_VERSION], [2.2.4]) となっていますが、僕のコミットしたものは 2.2.6 。ここか。 -- [[ひげぽん]] &new{2009-03-02 (月) 19:34:30};
 --2.2.4のlibtoolize入ってました。2.2.4のやつは実行権限とったのでもう混入することはないはず・・・ -- [[ココサブ]] &new{2009-03-02 (月) 20:25:52};
 ---お疲れ様です。早速の対応ありがとうございます!その状態で find . -name "*.m4" |xargs rm  ; autoreconf -ifv をしてコミットしていただけないでしょうか。それを各自がチェックアウトしてコンパイルできれば問題解決という事で。 -- [[ひげぽん]] &new{2009-03-02 (月) 20:28:14};
 ---コミットしました。これで解決するとよいのですが。  ちなみに実行権限とっただけでは駄目だったようで、ltversion.m4ってのも問題でした。インストールの順番とかの問題だったのかもしれません。 -- [[ココサブ]] &new{2009-03-02 (月) 20:54:53};
 ---おー。共存しているとどちらが使われるか微妙なんですね。僕も気をつけます。svn up してビルドできました。 -- [[ひげぽん]] &new{2009-03-02 (月) 21:43:46};
 ---ビルドできました。http://storage.osdev.info/pub/buildbot/mosh/status/1264/ -- [[.mjt]] &new{2009-03-02 (月) 23:58:18};

リロード   新規 編集 差分 添付 複製 改名   トップ 一覧 検索 最終更新 バックアップ   ヘルプ   最終更新のRSS

Modified by mona
PukiWiki 1.4.6 Copyright © 2001-2005 PukiWiki Developers Team. License is GPL.
Based on "PukiWiki" 1.3 by yu-ji
Powered by PHP 5.2.17
HTML convert time to 0.053 sec.